Кто любит RISC в жизни, заходим, не стесняемся.
Ответить

STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 14:49:42

Добрый день.

Попытался развести схема под stm32f103, но получил проблему, МК не реагирует на Boot0 и Boot1
В документации boot1 и boot0 подключены через резисторы 100кОм, на макетной плате они подключены через 10кОм и 100кОм соответственно. Пробовал разные варианты резисторов, сейчас оставил по 40кОм на каждом.
Но плата все равно не реагирует на них, в любом случае стартует прошивку из флэша.
При этом остальное все работает, лампочкой мигает и через Uart передает текст.

Кондансаторами пока пренебрег, без них должно же запуститься нормально, ставил кондеры на кварц, все равно толку не было.

Хочу прошить через Arduino IDE через serial (тапками не кидайтесь, нужна именно эта IDE), но при переключении boot1 и boot0 реакция одна и таже - запускается скетч. Подскажите, где я мог ошибиться.

-----
В файле stm32_sh.png BOOT1 всегда 0, но пересобрал схема на макетной плате с 2-мя переключателями, результат такой же.
Вложения
stm32_sh.png
Моя схема, надеюсь разберетесь
(24.21 KiB) Скачиваний: 179
stm32_min.png
Минимальная схема подключения stm32f103
(225.22 KiB) Скачиваний: 147

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 15:09:59

Boot1 должен сидеть на земле - это правильно.
Boot0 должен сидеть на земле для загрузки из флеша, либо же подтягиваться к Vdd для загрузки бутлоадера. Т.е. когда ты коротишь правую перемычку на "Boot0", загружается прошивка, а если закоротишь левую - как раз должен грузиться бутлодырь. Если это не так, значит, МК дохлый...
P.S. Там и 10кОм можно. 100кОм обычно ставят только на BOOT1, чтобы не мешал использовать ногу PB2.
P.P.S. Кондерами по питанию пренебрегать не стоит, иначе при активной работе возможен brown reset.

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 15:15:12

Если это не так, значит, МК дохлый.

Но магия в том, что я перепаиваю этот же МК обратно на Bluepill и с тем же UART переходником прошивка нормально загружается. Понимаю, что магии не существует, но где я мог допустить косяк ума не приложу.

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 15:22:46

reset без обвязки ?

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 15:31:13

reset без обвязки ?

Reset с резистором 10kOm на 3.3 вольта. Судя по данным в Serial отрабатывает правильно

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 15:38:21

конденсатор зажали ?

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 15:57:34

Друзья, спасибо всем за отзывчивость. Проблема решена. Перепаял резисторы на 10кОм и все заработало.

Очередной раз проклянаю "Безотмывочный" флюс, которым которым все поял и убеждаюсь что любой флюс, пасты и прочее надо отмывать. Даже канифоль надо отскабливать от контактов, чтоб случайно где-то не было сюрпризов. Видимо где-то пробивало и 50кОм не хватало.

Добавлено after 14 minutes 36 seconds:
Вообще платы у меня как Оливье - на 2-й день (вкуснее) работают лучше. Когда весь флюс и продсхонет, видимо надо мне подбирать новую химию

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 16:14:08

Reset с резистором 10kOm на 3.3 вольта.

Не нужно reset к Vdd подтягивать: он уже подтянут внутри чипа. Разве что кондер на 0.1мкФ повесить, если кнопкой сброс происходит.

Re: STM32 нет реакции на boot0 и boot1

Пт ноя 22, 2019 16:21:54

Не нужно reset к Vdd подтягивать: он уже подтянут внутри чипа. Разве что кондер на 0.1мкФ повесить, если кнопкой сброс происходит.


Спасибо, действовал по документации, там написано, что подтянуть надо. Буду знать и экономить место :)
Кондеры я на тестовой плате не стал делать, хотел только проверить разводку, что в принципе и получилось.

Re: STM32 нет реакции на boot0 и boot1

Сб ноя 23, 2019 14:50:21

действовал по документации, там написано, что подтянуть надо.

Это ж в какой такой "документации" написано, что нужно подтягивать, если в даташите четко нарисовано, что на NRST есть внутренняя подтяжка?
Ответить